https://bugs.openldap.org/show_bug.cgi?id=10418
Issue ID: 10418 Summary: Typo in man page for slapcat Product: OpenLDAP Version: 2.6.10 Hardware: All OS: All Status: UNCONFIRMED Keywords: needs_review Severity: normal Priority: --- Component: documentation Assignee: bugs@openldap.org Reporter: hanspeter.dekoning@dekonsult.com Target Milestone: ---
In the slapcat man page, in the description of option -o under "Possible generic options/values are:" the following option is misspelled: ldif_wrap={no|<n>} the underscore should be a hyphen, like so: ldif-wrap={no|<n>}
Location is line 152 in: https://git.openldap.org/openldap/openldap/-/blob/master/doc/man/man8/slapca...
Correction tested and confirmed with slapcat in v2.6.10 on Linux / Ubuntu v24.04.
https://bugs.openldap.org/show_bug.cgi?id=10418
Ondřej Kuzník ondra@mistotebe.net changed:
What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |INVALID Status|UNCONFIRMED |RESOLVED
--- Comment #1 from Ondřej Kuzník ondra@mistotebe.net --- Actually, if you test it, `slapcat -o ldif_wrap=no` works just fine? At least it did for me just now.
https://bugs.openldap.org/show_bug.cgi?id=10418
--- Comment #2 from hanspeter.dekoning@dekonsult.com --- I just discovered my machine was actually running v2.4.57. It was installed and running in a Docker container.
In that version `slapcat -o ldif_wrap=no` returned the usage info, and did not do anything. However, `slapcat -o ldif-wrap=no` returned the expected output.
Checking the documentation for versions 2.4, 2.5 and v2.6, apparently the option name was changed from `ldif-wrap` in v2.4 to `ldif_wrap` in v2.5. Quite confusing, since the other -o options, e.g. `syslog-level`, are keeping the hyphen naming convention (kebab-case).
https://bugs.openldap.org/show_bug.cgi?id=10418
--- Comment #3 from Ondřej Kuzník ondra@mistotebe.net --- On Mon, Jan 05, 2026 at 07:57:59PM +0000, openldap-its@openldap.org wrote:
I just discovered my machine was actually running v2.4.57. It was installed and running in a Docker container.
In that version `slapcat -o ldif_wrap=no` returned the usage info, and did not do anything. However, `slapcat -o ldif-wrap=no` returned the expected output.
Checking the documentation for versions 2.4, 2.5 and v2.6, apparently the option name was changed from `ldif-wrap` in v2.4 to `ldif_wrap` in v2.5. Quite confusing, since the other -o options, e.g. `syslog-level`, are keeping the hyphen naming convention (kebab-case).
There were some changes to adjust for other libldap options yes, and I suppose I adjusted the manpage unnecessarily.
On the other hand the 2.4 manpage is in sync with the 2.4 version so we should be good there too.
Regards,
https://bugs.openldap.org/show_bug.cgi?id=10418
Quanah Gibson-Mount quanah@openldap.org changed:
What |Removed |Added ---------------------------------------------------------------------------- Keywords|needs_review | Status|RESOLVED |VERIFIED