https://bugs.openldap.org/show_bug.cgi?id=9185
Bug ID: 9185
Summary: glue entry
Product: OpenLDAP
Version: 2.4.48
Hardware: All
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: client tools
Assignee: bugs(a)openldap.org
Reporter: gnoe(a)symas.com
Target Milestone: ---
--
You are receiving this mail because:
You are watching someone on the CC list of the bug.
https://bugs.openldap.org/show_bug.cgi?id=9323
Issue ID: 9323
Summary: For 2.5, only support OpenSSL 1.0 or later
Product: OpenLDAP
Version: 2.5
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: libraries
Assignee: bugs(a)openldap.org
Reporter: quanah(a)openldap.org
Target Milestone: ---
Need to abort configure at the least if the OpenSSL release is less than the
1.0.x series when compiling against OpenSSL
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9302
Issue ID: 9302
Summary: ppolicy pwdFailureTime race condition leaves acccount
unlocked, violating pwdLockout policy
Product: OpenLDAP
Version: 2.4.50
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: overlays
Assignee: bugs(a)openldap.org
Reporter: requate(a)univention.de
Target Milestone: ---
Multiple concurrent ldap binds with invalid passwords against a user account
sometimes don't trigger account lockout, even though the number of failed
attempts exceeds the configured pwdLockout policy of the ppolicy overlay.
How to reproduce:
1. Configure ppolicy overlay with pwdLockout: TRUE
2. set pwdMaxFailure to some value, e.g. 5
3. Create a test user account and start just enough (or more) parallel
ldapsearch processes
to make the account get locked, e.g. like this in bash/sh (note the
backgrounding):
for i in $(seq 6); do
ldapsearch -x -D "uid=testuser1,$ldap_base" -w invalid >/dev/null 2>&1 &
done
4. Check relevant ppolicy attributes, like:
ldapsearch -x -H LDAPI:// -b "uid=testuser1,$ldap_base" + \
grep -E '^(pwdFailureTime|pwdAccountLockedTime):'
This often shows no pwdAccountLockedTime but enough (or more) pwdFailureTime
values to meet the lockout policy.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9320
Issue ID: 9320
Summary: ldapsearch nettimeout doesn't work with startTls when
the server address is not reachable
Product: OpenLDAP
Version: 2.5
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: client tools
Assignee: bugs(a)openldap.org
Reporter: allen.zhang(a)audiocodes.com
Target Milestone: ---
We found that ldapsearch doesn't return with failure according to the
nettimeout when the server address is not valid. it fails only after TCP
timeout (about 120 seconds in my environment).
we dug into in to the source code and found that :
in common.c, we set the nettimeout after ldap_start_tls_s is called.
We tried to call "ldap_set_option( ld, LDAP_OPT_NETWORK_TIMEOUT, (void *)
&nettimeout )" before ldap_start_tls_s and it works well!
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=8159
--- Comment #1 from Quanah Gibson-Mount <quanah(a)openldap.org> ---
So if the argument is "hard", then the code will use the "hard" limit set to
the general "sizelimit" parameter.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=8047
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Keywords|OL_2_5_REQ |
Target Milestone|2.5.0 |---
--- Comment #5 from Quanah Gibson-Mount <quanah(a)openldap.org> ---
Not possible until all SSL engines support async in the underlying SSL library,
which is currently not the case
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=8047
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |allen.zhang(a)audiocodes.com
--- Comment #4 from Quanah Gibson-Mount <quanah(a)openldap.org> ---
*** Issue 9320 has been marked as a duplicate of this issue. ***
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9022
--- Comment #1 from Quanah Gibson-Mount <quanah(a)openldap.org> ---
An ability to do this for environments where old serverIDs have been retired
would be useful as well. This came up today on the -technical list, where
there are 4 SIDs in the DB, but some have been retired and are left over from
previous migrations.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=7639
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Keywords|OL_2_5_REQ |
Resolution|--- |TEST
Status|UNCONFIRMED |RESOLVED
--- Comment #5 from Quanah Gibson-Mount <quanah(a)openldap.org> ---
Commits:
• edc94862
by Howard Chu at 2020-08-29T00:13:19+00:00
ITS#7639 fix crash in config_delete
Additional fix to 41352ea34da225375b77254efdcde8e6e5a1a515
The overlay must be deleted from the backend before the
callback can execute. In particular, it must be done before
the threadpool is unpaused.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=8427
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Resolution|--- |TEST
Status|UNCONFIRMED |RESOLVED
Keywords|OL_2_5_REQ |
--- Comment #29 from Quanah Gibson-Mount <quanah(a)openldap.org> ---
Commits:
• f883a575
by Howard Chu at 2020-08-28T18:44:35+01:00
ITS#8427 don't set tls_ctx if TLS wasn't requested
Also, set any remaining TLS options that weren't carried along
in the TLS ctx.
--
You are receiving this mail because:
You are on the CC list for the issue.