https://bugs.openldap.org/show_bug.cgi?id=8440
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Target Milestone|2.5.0 |2.5.1
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=8479
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|RESOLVED |VERIFIED
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=8009
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|RESOLVED |VERIFIED
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=6301
Quanah Gibson-Mount <quanah(a)openldap.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|RESOLVED |VERIFIED
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9351
Issue ID: 9351
Summary: Always build monitor, and force it to be static.
Product: OpenLDAP
Version: 2.5
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: backends
Assignee: bugs(a)openldap.org
Reporter: quanah(a)openldap.org
Target Milestone: ---
With 2.5, the monitor backend should always be enabled and built as a static
module rather than dynamic.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9349
Issue ID: 9349
Summary: Performance problem when trying to remove a value from
an indexed attribute
Product: OpenLDAP
Version: 2.4.45
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: backends
Assignee: bugs(a)openldap.org
Reporter: gbuades(a)soffid.com
Target Milestone: ---
Created attachment 762
--> https://bugs.openldap.org/attachment.cgi?id=762&action=edit
Patch to improve attribute removal
I have an LDAP with MDB backend, and a groupOfUniqueNames with 50.000 members.
The uniqueMember attribute is indexed.
When I try to remove a single user, the process takes more or less one minute
to complete.
After debugging, I've just found out the process to identify the old values to
remove from the index is not optimum, as the time required to compare the old
and the new values depends on number of values ^ 2.
Taking advantage of the fact, that the values in the old and new attributes are
ordered in the same way, I've build a patch to opmtimize this search process.
Now, the same operation takes 0.2 seconds, when it used to take 50s.
Thanks a lot for your effort, and I hope this contribution helps you and other
users.
The attached file is derived from OpenLDAP Software. All of the modifications
to OpenLDAP Software represented in the following patch(es) were developed by
Soffid. Soffid has not assigned rights and/or interest in this work to any
party. I, Gabriel Buades am authorized by Soffid, my employer, to release this
work under the following terms.
Soffid hereby place the following modifications to OpenLDAP Software (and only
these modifications) into the public domain. Hence, these modifications may be
freely used and/or redistributed for any purpose with or without attribution
and/or other notice.
The attached modifications to OpenLDAP Software are subject to the following
notice:
Copyright 2020 Soffid
Redistribution and use in source and binary forms, with or without
modification, are permitted only as authorized by the OpenLDAP Public License.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9348
Issue ID: 9348
Summary: libldap uses deprecated symbols sys_errlist and
sys_nerr
Product: OpenLDAP
Version: 2.4.53
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: libraries
Assignee: bugs(a)openldap.org
Reporter: ditu.alexandru(a)gmail.com
Target Milestone: ---
Starting with libc >= 2.32 the symbols sys_errlist and sys_nerr are removed:
From the release notes
(https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=NEWS;hb=HEAD):
* The deprecated symbols sys_errlist, _sys_errlist, sys_nerr, and _sys_nerr
are no longer available to newly linked binaries, and their declarations
have been removed from from <stdio.h>. They are exported solely as
compatibility symbols to support old binaries. All programs should use
strerror or strerror_r instead.
Their usage should be removed from libldap (include/ac/errno.h) and replaced
with strerror or strerror_r.
Otherwise any library that uses libldap compiled with libc < 2.32 won't run on
systems that use newer libc versions (>= 2.32).
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9346
Issue ID: 9346
Summary: test063 only supports 2 servers, should handle up to 9
Product: OpenLDAP
Version: 2.4.52
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: build
Assignee: bugs(a)openldap.org
Reporter: hyc(a)openldap.org
Target Milestone: ---
And the default should be 4, as with test050 etc.
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9344
Issue ID: 9344
Summary: test067-tls fails on solaris 10 due to unescaped
quotes in quoted string
Product: OpenLDAP
Version: 2.5
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: build
Assignee: bugs(a)openldap.org
Reporter: quanah(a)openldap.org
Target Milestone: ---
This statement in test067 causes it to fail in solaris 10:
TLS_PEERKEY_HASHED_FAIL="$TLS_PEERKEY_HASHALG:`echo "a fake key to
hash" | \
"${openssl}" dgst "-$TLS_PEERKEY_HASHALG" -binary 2>/dev/null |
\
"${openssl}" enc -base64 2>/dev/null`"
Solaris10's shell requires the quotes here to be escaped, like:
TLS_PEERKEY_HASHED_FAIL="$TLS_PEERKEY_HASHALG:`echo \"a fake key to
hash\" | \
"${openssl}" dgst "-$TLS_PEERKEY_HASHALG" -binary 2>/dev/null |
\
"${openssl}" enc -base64 2>/dev/null`"
With this change the test passes
--
You are receiving this mail because:
You are on the CC list for the issue.
https://bugs.openldap.org/show_bug.cgi?id=9335
Issue ID: 9335
Summary: test068 fails when openldap is built without SASL
support
Product: OpenLDAP
Version: 2.5
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: ---
Component: build
Assignee: bugs(a)openldap.org
Reporter: quanah(a)openldap.org
Target Milestone: ---
Need to fix test068 to test for SASL support.
--
You are receiving this mail because:
You are on the CC list for the issue.