Hi all,

I am new to openldap and i manage dto install and configure the same. My linux client is working well but not able to authenticate windows and mac clients.

Have been trying since past 2 days by google and other posts but still facing issue. Any help would be highly appreciated.

using openldap-2.4.23-34 on RHEL6.5
Client details:
Mac 10.8.5 -- tried configuring the network account server but it is showing RED. Error This server is not responding.
Windows 7 – tried installing GINA but it is giving me invalid credentials error.
Configuration file on server:
# extended LDIF
# LDAPv3
# base <dc=j,dc=example,dc=com> (default) with scope subtree
# filter: (objectclass=*)
# requesting: ALL
# j.example.com
dn: dc=j,dc=example,dc=com
objectClass: top
objectClass: dcObject
objectClass: organization
o: example Organization
description: example Inc DIT
dc: j
# Users, j.example.com
dn: ou=Users,dc=j,dc=example,dc=com
objectClass: organizationalUnit
ou: Users
# Groups, j.example.com
dn: ou=Groups,dc=j,dc=example,dc=com
objectClass: organizationalUnit
ou: Groups
# Admins, j.example.com
dn: ou=Admins,dc=j,dc=example,dc=com
objectClass: organizationalUnit
ou: Admins
# sohri, Users, j.example.com
dn: uid=sohri,ou=Users,dc=j,dc=example,dc=com
uid: sohri
cn: sohri
sn: 1
objectClass: top
objectClass: posixAccount
objectClass: inetOrgPerson
loginShell: /bin/bash
homeDirectory: /home/sohri
uidNumber: 15000
gidNumber: 10000
userPassword:: e1NTSEF9eWdkWExpZUdIT01YRytRM3ZmZWdNY3QwSmd2bFNqSkcg
mail: sam.ohri@example.com
gecos: Local User
# tpearce, Users, j.example.com
dn: uid=tpearce,ou=Users,dc=j,dc=example,dc=com
uid: tpearce
cn: tpearce
sn: 2
objectClass: top
objectClass: posixAccount
objectClass: inetOrgPerson
loginShell: /bin/bash
homeDirectory: /home/tpearce
uidNumber: 15001
gidNumber: 10000
userPassword:: e1NTSEF9eWdkWExpZUdIT01YRytRM3ZmZWdNY3QwSmd2bFNqSkc=
mail: tony.pearce@example.com
gecos: local User
# ldapusers, Groups, j.example.com
dn: cn=ldapusers,ou=Groups,dc=j,dc=example,dc=com
objectClass: posixGroup
objectClass: top
cn: ldapusers
userPassword:: e2NyeXB0fXg=
gidNumber: 10000
memberUid: uid=sohri
memberUid: uid=tpearce
# search result
search: 2
result: 0 Success
# numResponses: 8
# numEntries: 7