I encountered a problem with openldap-2.4.40 on debian when a vm crashed. Upon restore i could not start slapd service. But typing slapd on the command line would start slapd. I tried defining the urls, and tried defining the configuration directory with the slapd command, however that only resulted in the same error.

After extensive searching i could only find one reference to the error "daemon: bind(11) failed errno=2 (No such file or directory)". and that was leading me in the direction of the directory /var/run/ldap didnt have the right permissions, but it was there and had openldap owner and group. I spent a number of hours double checking directories making sure everything was there and had the right permissions.

I finally found /var/run/slapd was missing! A file called ldapi is created there on startup.

What is /var/run/slapd/ldapi ??

And what does it do?

For future reference what is bind(11) referring to? Where can i find the reference to error codes?

Thanks for your help,

Alan Lukens

Identity Management Specialist

University of Massachusetts Amherst, IT NSS

voice: 413.545.1654

email: alan.lukens@umass.edu