Thanks for the information.

I tried few more tests,slapcat doesn't always hang and it hangs every second restart of slapd.
I don't know really whether it is sharing of locks issue or something else.

Currently lock detect is set to DB_LOCK_DEFAULT even if I increase the lock detect to Maximum locks no change in the state of slapcat.

If I upgrade BDB will this solve the issue of slapcat hanging ? , Have your faced such situation of hanging in slapcat

I get this below message when I run the slapcat and it never goes forward

5452a973 The first database does not allow slapcat; using the first available on e (2)


On Thu, Oct 30, 2014 at 7:41 PM, Quanah Gibson-Mount <> wrote:
--On Thursday, October 30, 2014 6:04 PM +0100 pramod kulkarni <> wrote:

Thanks for the response.
What if I disable the alock file generation in the back-bdb
initialization? will it affect other functionalities like replication etc.

You should understand what the alock file is for before you think about deleting it.  It tracks the state of your database.  If your slapcat is hanging, it sounds like you have DB corruption at the BDB level.



Quanah Gibson-Mount
Server Architect
Zimbra, Inc.
Zimbra ::  the leader in open source messaging and collaboration