On Tue, Apr 5, 2011 at 1:52 PM, sim123 <Sim3159@gmail.com> wrote:

On Tue, Apr 5, 2011 at 9:54 AM, Quanah Gibson-Mount <quanah@zimbra.com> wrote:

--On April 5, 2011 9:38:24 AM -0700 sim123 <Sim3159@gmail.com> wrote:

Thanks for your reply, I don't need to use mozilla NSS however when I
compile --with-tls flag I get error saying - NSS library is not found,
please include NSS and NSPR in CPPFLAGS and LDFLAGS. So I followed FAQ
and included NSS libs. And FAQ suggested to set --with-tls=no so that NSS
implementation can be used.
Could you please guide me on setting this up. Thanks.

If you read the ./configure -h output, you'll see that --with-tls takes an option.  That option is the name of the TLS implementation you are trying to link to.  For example, I use OpenSSL so:

      --with-tls=openssl \


Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration

Thanks for your reply, I tried your suggestion and used this for configure
./configure --prefix=/root/Desktop/openldap-2.4.25 --with-tls=openssl --with-cyrus-sasl --enable-crypt --enable-debug --enable-cleartext

However this time I can not even configure and get error message:

checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
checking for SSL_library_init in -lssl... no
checking for ssl3_accept in -lssl... no
configure: error: Could not locate TLS/SSL package

I have OpenSSL 0.9.8e-fips-rhel5 installed via yum on cenos 5.2. I tried searching archives but could not find any solution there. Thanks for the help.

 After doing some more search I found this post


Everything works except make test for openldap fails with error

./scripts/test000-rootdse: line 66: kill: (11073) - No such process
../clients/tools/ldapsearch: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
>>>>> Test failed
>>>>> ./scripts/test000-rootdse failed for bdb (exit 127)
make[2]: *** [bdb-yes] Error 127

I am using openldap 2.4.25, Berkeley DB 4.8.30, openssl 1.0.0, cyrus-sasl 2.1.23

and my path variables are set to

export PATH=/usr/bin:/usr/sbin:/bin:/sbin:/opt/openssl-1.0.0/lib:/opt/db-4.8.30/lib:/opt/db-4.8.30/include

export LD_LIBRARY_PATH=/opt/db-4.8.30/lib

export SASL_PATH=/opt/cyrus-sasl-2.1.23/sasl2

export CPPFLAGS="-I/opt/db-4.8.30/include -I/opt/openssl-1.0.0/include -I/opt/cyrus-sasl-2.1.23/include"

export LDFLAGS="-L/opt/db-4.8.30/lib -L/opt/openssl-1.0.0/lib -L/opt/cyrus-sasl-2.1.23/lib"

export LIBS="-lgcc_s"

I checked that libssl.so.1.0.0 is present in /opt/openssl-1.0.0, so no clue :(
I will keep trying and would very much appreciate any help.