Thanks for taking time to anwser. I really appreciate it

Yep, that was an error I made when I redacted the email and changed the the rootdn to not leak info about my environment (which might be stupid since this is just a home lab)

I tried installing openldap in Fedora 32 (openldap 2.4.47-4.fc32), Opensuse Tumbleweed (openldap 2.4.49-51.2), Alpine (openldap 2.4.49-r3) and Freebsd(openldap 2.4.50) using similar slapd.ldif in all variants (just minor path modifications so slapdadd can find schemas, etc)
i got the same error about str2ad(olcDbMaxSize): attribute type undefined in all of my attempts except for Fedora 32 (openldap 2.4.47-4.fc32) where the slapdadd dry-run completed without errors and I was able to configure and start slapd completely through OLC

I'm currently investigating how to downgrade openldap on my target OS and maybe try both 2.4.47 and 2.4.48

kind regards

On Fri, May 1, 2020 at 5:25 AM A. Schulze <> wrote:

Am 30.04.20 um 16:19 schrieb Beker:
> olcRootDN: cn=mdbadm,test,dc=local

shouldn't this be "cn=mdbadm,dc=test,dc=local" ?