ldapsearch -x -H ldap:// "cn=Directory Manager" "(objectclass=*)" -W _e3user


2010/3/1 Cool The Breezer <>
I tried as per suggestions using man page. But still getting the error

ldapsearch -H ldap:// "cn=Directory Manager" "(objectclass=*)" -W -X _e3user
Enter LDAP Password:
SASL/EXTERNAL authentication started
ldap_sasl_interactive_bind_s: Unknown authentication method (-6)
       additional info: SASL(-4): no mechanism available:

It now generates a new error. I tried using authconfig with --enableldap,  --enablewinbind  and  --disableldaptls.
Still users are not able to login to linux box using LDAP credentials.

----- Original Message ----
From: Jonathan Clarke <>
To: Cool The Breezer <>
Sent: Mon, March 1, 2010 1:16:32 PM
Subject: Re: OpenLDAP client configuration with CentOS 5.3

Le 01/03/2010 06:53, Cool The Breezer a écrit :
> Thanks for your suggestion. But still there is some problem.
> /ldapsearch -H ldap:// -x -LL
> ou=people,dc=jnpr,dc=net "{mail=*norton*}" sn cn mail/
> /
> /
> /Output: version: 1/
> /
> /
> /Operations error (1)/
> /Additional information: 00000000: LdapErr: DSID-0C090627, comment: In
> order to perform this operation a successful bind must be completed on
> the connection., data 0, vece/
> Not sure the reason behind such errors. I think there is something
> wrong, because when I am trying to login linux box using ldap
> credentials, it simply closes the connection.

As it says in this error message: "a successful bind must be completed on the connection". This means you must authenticate to the LDAP server in order to search in it.

Check the -D and -w/-W options in the ldapsearch(1) man page. You'll need a valid account in your LDAP server and it's password.

-- --------------------------------------------------------------
Jonathan Clarke -
Ldap Synchronization Connector (LSC) -

| Echedey Lorenzo Arencibia  |