Low Sensitivity/Aerospace Internal Use Only

Hi Vikas, I have altered my command line to do the following now:

ldapmodify  -x -D "cn=admin,cn=config"   -W  -d 256 -h wsf-LabLDAP.lab.aero.org -p 389 -P 3

I still get the exact same error, no change at all.

Warron French, MBA, SCSA

From:        Vikas Parashar <para.vikas@gmail.com>
To:        Warron S French <Warron.S.French@aero.org>,
Cc:        openldap-technical@openldap.org
Date:        01/24/2014 12:09 PM
Subject:        Re: OpenLDAP slapd problems - ldap_result: Can't contact LDAP server (-1) --- Low Sensitivity/Aerospace Internal Use Only


That error is clearly saying. "unable to connect" that's mean you need to pass host as well..

On Fri, Jan 24, 2014 at 9:58 PM, Warron S French <Warron.S.French@aero.org> wrote:
Low Sensitivity/Aerospace Internal Use Only

Working on a CentOS-6.5 server, running LTB Project's  slapd-2.4.38.

Someone suggested I implement a cn=admin,cn=config for a cn=config setup.  (I don't know how to technically word that).

Anyway, I need to make TLS-related changes and was told to do the following command:

ldapmodify  -x -D "cn=admin,cn=config"   -W  -d 256

...then at the blank line type the following, each on a single line:

Dn:                                      cn=config

Changetype:                      modify

Add:                                      olcTLSCipherSuite

OlcTLSCipherSuite:        HIGH:MEDIUM+TLSv1+SSLv3


I have been getting an error reponse of:

ldap_result:  Can't contact LDAP server (-1)

This __ONLY__ occurs after I hit <CTRL-D>, not before.  Yes, the daemon, slapd, is actually running, but after this failure it abruptly stops.  I know this because in a separate terminal on the same system, I am running a while-loop with a ps -e | grep slapd in it.

Please note the "-x" option according to the man page for ldapmodify is supposed to Use simple authentication instead of SASL.

Thank you all for your help, hopefully you can:

1) tell me what this error means, and

2) how to fix my problem so that I can complete the olcTLSxxxx changes I need to implement.

Warron French, MBA, SCSA

Low Sensitivity/Aerospace Internal Use Only

Low Sensitivity/Aerospace Internal Use Only