Hi Quanah,

Sorry about my delay to answer you, I've been in vacation and away from PC. 

I understand that I should use the same name when I'll update this file to make it easy, but it is a new installation and this reason that I need modify this entries.

I've tested your suggestion and delete operation has worked fine, but I've still had the same problem described previously when I've tried add new olcTLSCertificateFile or new olcTLSCertificateKeyFile or new olcTLSCACertificateFile. I don't understand the reason for that.

[root@localhost ldifs]# ldapmodify -Y EXTERNAL -H ldapi:/// -f 5tls.ldif
SASL/EXTERNAL authentication started
SASL username: gidNumber=0+uidNumber=0,cn=peercred,cn=external,cn=auth
modifying entry "cn=config"
ldap_modify: Other (e.g., implementation specific) error (80)

Igor Sousa

Em sex, 28 de jun de 2019 às 21:53, Quanah Gibson-Mount <quanah@symas.com> escreveu:
--On Friday, June 28, 2019 7:33 PM -0300 Igor Sousa <igorvolt@gmail.com>

> dn: cn=config
> changetype: modify
> replace: olcTLSCertificateFile
> olcTLSCertificateFile: /etc/openldap/certs/ldap.local.crt
> -
> replace: olcTLSCertificateKeyFile
> olcTLSCertificateKeyFile: /etc/openldap/certs/ldap.local.key
> -
> add: olcTLSCACertificateFile
> olcTLSCACertificateFile: /etc/openldap/certs/ca.cert.pem

I would suggest simply using the same filenames as you had before, negating
the need to modify the attributes at all.  You're likely hitting ITS#8286
with the replace operations.  Another idea may be to change replace to a
delete+add in the same operation sequence.



Quanah Gibson-Mount
Product Architect
Symas Corporation
Packaged, certified, and supported LDAP solutions powered by OpenLDAP: