I am using port 636 (and OpenLDAP 2.4.23) here is the ldapsearch command that I run:


$ ldapsearch -W -x -H ldaps://<server1>.example.ldap -v -D "cn=admin,cn=config" "(objectClass=*)"




From: openldap-technical-bounces@OpenLDAP.org [mailto:openldap-technical-bounces@OpenLDAP.org] On Behalf Of c chupela
Sent: Wednesday, January 22, 2014 4:20 PM
To: Michael Ströder; openldap-technical@openldap.org
Subject: Re: problem with accessing secure ldap


Ok, I've tried running ldapsearch on the host with the problem,  and rec'd the following error:


ldap_result: Can't contact LDAP server (-1)


command I used was 


ldapsearch -p 636 -h localhost -b "dc=xxxxx,dc=yyyyy,dc=zzzz,dc=ccc"   "(objectclass=*)"








On Wednesday, January 22, 2014 2:14 PM, Michael Ströder <michael@stroeder.com> wrote:

c chupela wrote:

> I've been tasked with figuring out why a redhat 6.4 server w/openldap v2.4.23 is not accessible.
> I can telnet to port 389 on this server from another server, but not to port 636 - putty will throw back an immediate 'connection closed by remote host' message.

Why don't you try with ldapsearch command-line tool?

Ciao, Michael.