Hi Michael,

I've also tried to add the "moduleload" and "modulepath" directives at the top of slapd.conf (but after the include schema block). Anyway before any database definition.

I either tried with
moduleload      unique
and with
moduleload      unique.o

Unfortunately no success.

Might it be that my re-compiling procedure was incorrect ? I described it in my first post.
Or, might it be that the root user is not "blocked" from that unique overlay ?

Thanks for the important support! I've run out of ideas :-/


2015-08-24 16:45 GMT+02:00 Michael Ströder <michael@stroeder.com>:
Simone Taliercio wrote:
> I tried your suggestion, but it does not really like it:
> /usr/local/etc/openldap/slapd.conf: line 90: unknown directive <unique_uri>
> inside backend database definition.

Make sure the overlay module gets loaded with this configuration directive in
the global section of your slapd.conf:

moduleload unique

The global section consists of all configuration directives *before* your
first database directive.

Ciao, Michael.