I'm trying to use ldapsearch to do some tests, lets say the testing ldap server host is: ldap.forumsys.com ,
test 1:
 if I run:
ldapsearch -h ldap.forumsys.com -p 389 -b "" -s base "(objectClass=*)" -D "cn=read-only-admin,dc=example,dc=com"  -w password 
it seems successful, but if I add ssl flag, like run:
ldapsearch -h ldap.forumsys.com -p 389 -b "" -s base "(objectClass=*)" -D "cn=read-only-admin,dc=example,dc=com"  -w password -Z 
I got error:
ldap_start_tls: Connect error (-11)
 additional info: (unknown error code)
ldap_result: Can't contact LDAP server (-1)

if I run:
ldapsearch -h ldap.forumsys.com -p 636 -b "" -s base "(objectClass=*)" -D "cn=read-only-admin,dc=example,dc=com"  -w password -Z 
I got error: 
ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)
 so how can I do a search with ssl?
test 2:
      this is about SASL authentication. Lets say the SASL mech is DIGEST-MD5, or EXTERNAL, or GSSAPI, what ldapsearch command
should I run? I tried many, it did not work.


Peter Sui